golang-sigs-k8s-structured-.../golang-sigs-k8s-structured-merge-diff.spec

84 lines
1.7 KiB
RPMSpec

# Generated by go2rpm 1.15.0
%bcond check 0
%bcond bootstrap 0
%if %{with bootstrap}
%global debug_package %{nil}
%endif
%if %{with bootstrap}
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^golang\\(.*\\)$
%endif
%global debug_package %{nil}
# https://github.com/kubernetes-sigs/structured-merge-diff
%global goipath sigs.k8s.io/structured-merge-diff
%global forgeurl https://github.com/kubernetes-sigs/structured-merge-diff
Version: 4.4.2
%gometa -f
%global goaltipaths sigs.k8s.io/structured-merge-diff/v4
%global common_description %{expand:
Test cases and implementation for "server-side apply".}
%global golicenses LICENSE
%global godocs CONTRIBUTING.md README.md RELEASE.md code-of-\\\
conduct.md
Name: %{goname}
Release: %autorelease -b 3
Summary: Test cases and implementation for "server-side apply"
License: Apache-2.0
URL: %{gourl}
Source: %{gosource}
%description %{common_description}
%gopkg
%prep
%goprep -A
%dnl %autopatch -p1
%if %{without bootstrap}
%generate_buildrequires
%go_generate_buildrequires
%endif
%if %{without bootstrap}
%build
for cmd in smd; do
%gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done
%endif
%install
%gopkginstall
%if %{without bootstrap}
install -m 0755 -vd %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/
%endif
%if %{without bootstrap}
%if %{with check}
%check
%gocheck
%endif
%endif
%if %{without bootstrap}
%files
%license LICENSE
%doc CONTRIBUTING.md README.md RELEASE.md code-of-conduct.md
%{_bindir}/*
%endif
%gopkgfiles
%changelog
%autochangelog